Discussions‎ > ‎

MTS Today ?

#9: www.ida.ca – Michigan Terminal System (MTS) notes

posted Dec 6, 2015, 6:28 AM by Jeff Ogden

A web page that provides a lot of good information about how to get started using MTS under Hercules, particularly for people already familiar with Unix.

See: http://www.ldx.ca/notes/mts-notes.html

Not sure who the author of this site is. idx.ca is in the country domain for Canada which might indicate some involvement from someone associated with UBC, Alberta (UQV), or SFU. Then again, it might not.

#8: Hercules in October 2014

posted Oct 16, 2014, 8:41 AM by Jeff Ogden   [ updated Oct 16, 2014, 8:41 AM ]

Here is a series of e-mail exchanged between Jeff, Mike, and Gavin in October 2014:

On October 14, 2014 at 3:20:01 AM -0400 Jeff Ogden wrote:

I stopped paying attention to Hercules developments about two years
ago when we went on one of our trips.  I'm trying to catch up now.
Here is what I've doped out. Could you let me know if this is more or
less correct?

The version of Hercules that I've been running on my Mac is 3.07 from
November 2012.

The web site for Hercules is http://www.hercules-390.eu.
http://www.hercules-390.org still exists, but it is out of date and
gives you the 3.07 version of Hercules.

The bugs or missing features that were causing MTS D6.0 and D6.0A
problems seem to have been fixed in version 3.08 from July 2013.
  • 3420 sense code corrections for MTS (Harold Grovesteen)
  • 1403 and 3211 FCB support (Enrico Sorichetti)
I think that is everything we need for D6.0 and D6.0A.

The current version is  3.11 from September 2014.

There is a 3.11 binary for 32-bit and 64-bit Windows, but nothing for
Unix or Mac OS X.

So, you pretty much need to build Hercules from the source for Unix
or Mac OS X. That is probably too much trouble for many people.


On Oct 14, 2014, at 2:46 PM, Mike Alexander wrote:

It's not that simple.  Hercules went through a near death experience a
while ago. Officially it hasn't forked, but in practice it has. There are now
two versions of the project: the semi-commercial version that you found
and the open source "Hyperion" version that is available from
<https://github.com/hercules-390/hyperion/>.  Neither is a subset of the
other, but the Hyperion version is getting a lot more development at the
moment.  It is known as version 4.xx while the semi-commercial version
is known as 3.xx, however this is misleading since neither is a derivative
of the other. It is confusing.


On October 14, 2014 at 3:22:04 PM -0400 Jeff Ogden wrote:

Do both versions include the two fixes we want / need?
  • 3420 sense code corrections for MTS (Harold Grovesteen)
  • 1403 and 3211 FCB support (Enrico Sorichetti)
I guess that we only need the second fix for D6.0A and that we want
both for D6.0 and D7.0 or whatever we end up calling the 1996 version.


On Oct 14, 2014, at 5:16 PM, Mike Alexander wrote:

I think those fixes are in both versions, but I would have to check to be sure.

I thought you were talking about using it yourself.  If you're just trying to find
a version to recommend to others, either should be ok. They can pick the
version they want themselves.

            Mike


On Oct 14, 2014, at 6:44 PM, Gavin Eadie wrote:

Identical tape fixes are in both in file "tapeccws.c":

SPINHAWK

Commit: f8a54ec051e12e104f9ac968773ee69c9e7d3469 [f8a54ec]
Author: Harold Grovesteen
Date: March 11, 2012 at 7:59:02 AM EDT
Committer: rbowler
Commit Date: October 17, 2012 at 3:58:37 PM EDT

Correct 3420 handling of TUA/B sense bits as required by MTS

HYPERION

Commit: b540a48b327004c976f26179b7f6f02213fe0dfa [b540a48]
Parents: afde96e072
Author: Harold Grovesteen
Date: March 11, 2012 at 7:59:02 AM EDT

Correct 3420 handling of TUA/B sense bits as required by MTS


On Oct 14, 2014, at 1:40 PM, Gavin Eadie wrote:

Jeff Ogden wrote: So, you pretty much need to build Hercules from the source for Unix or Mac OS X. That is probably too much trouble for many people.

Assuming you have compilers etc, and some knowledge, build isn't too hard:

$ git clone https://github.com/rbowler/spinhawk.git
$ cd spinhawk/
$ sh autogen.sh
$ ./configure
$ make
$ make install

$ hercules
    Hercules Version 3.11
    (c)Copyright 1999-2010 by Roger Bowler, Jan Jaeger, and others
    Built on Oct 14 2014 at 13:20:17
    Running on Ramsay-Mobile.local Darwin-14.0.0.Darwin Kernel Version 14.0.0: Tue Sep 23 23:01:41 x86_64 MP=8


On Oct 14, 2014, at 8:09 PM, Gavin Eadie wrote:

These build commands fail for “Hyperion” because of an error in determining
the version of the C compiler in autogen.  The result is a -flag emitted which
the compiler doesn’t understand.  This bug is known and fixing it is “in work”
according to the Hyperion “issues” page.  I’ve patched round it so I have
working versions of 3.11 and 4.00 .. Gav

#7: Try MTS

posted Sep 10, 2014, 2:55 PM by Jeff Ogden   [ updated Sep 10, 2014, 2:56 PM ]

Try MTS is an independent web site, created by Rupert Lane in June 2014. It provides information about installing and running MTS under Hercules and an introduction to using MTS.

#6: MTS running on a Raspberry Pi

posted Dec 11, 2012, 1:18 PM by Jeff Ogden   [ updated Dec 11, 2012, 1:41 PM ]

On December 8th and 11th 2012 Richard Chycoski posted two items to the H390-MTS e-mail group.



From: "u4gh" [Richard Chycoski]
Subject: [H390-MTS] MTS in my pocket!
Date: December 8, 2012 4:40:21 PM EST
To: H390-MTS@yahoogroups.com

Using Hercules and the Raspbian release of Linux, I have MTS running on a Raspberry Pi: <http://www.raspberrypi.org/faqs>.

It takes about 20 minutes to IPL and wait for the *NAL tasks to complete. I don't recall exactly how long MTS took to IPL on our first 370/148, but it was in the same ballpark (maybe ten minutes?). The Pi that I ran it on is also my household DNS/DHCP/IMAP/Sendmail server, but those processes were pretty quiet at the time. Top shows about 30% CPU when MTS is idle.

I have several Pis now, and am making one 'portable'. Who woulda thought we could have MTS literally in our pocket, running for several hours on 4 AA cells? :-)



--- In H390-MTS@yahoogroups.com, Jeff Ogden wrote:

Pretty cool! Any chance I can talk you into taking a photo or two?

 -Jeff



From: "u4gh"
Subject: [H390-MTS] Re: MTS in my pocket!
Date: December 11, 2012 12:45:55 PM EST
To: H390-MTS@yahoogroups.com

Sure, Jeff - I've uploaded a picture of my WiFi-enabled Raspberry Pi to the photos section of the group, and a screen shot from my iPhone which is connected to the Pi via SSH and VNC. Not only does the data centre fit in my pocket, but the 3278 does too. :-)

I copied my MTS/Hercules install to this Pi. It is plugged in to a wall-wart, I need to solder up a cable to power it from four AA cells. On an 8 GB SD card for 'disk', I have about 4.7 GB free.

The Pi as seen here with all of it's attachments (SD memory card and WiFi dongle) is 2.5 x 5 inches in size. It idles at about 3.5 watts and maxes out at 5 watts. I'm getting a small video display to attach to the analog video output, and I have a wireless keyboard/trackpad to make for a complete, standalone system. When I get the whole thing together I'll send in another picture.

- Richard [Chycoski]


Photo of an IPhone with the MTS signon screen
 
Photo of a Raspberry Pi running MTS under Hercules under Linux

#5: Comments from Facebook

posted Jan 13, 2012, 8:30 AM by Jeff Ogden   [ updated Jan 18, 2012, 7:17 PM ]




#3: MTS made available on 22 December and running under Hercules on 24 December 2011

posted Jan 7, 2012, 2:27 PM by Jeff Ogden   [ updated Jan 13, 2012, 5:26 PM ]


The following item was posted to the CC Talk (Classic Computing) list on 22 December 2011:

Al Kossow
Thu Dec 22 16:21:43 CST 2011
the sources and binaries for MTS are now available under
http://bitsavers.org/bits/UniversityOfMichigan/mts/

Al Kossow is the software curator at the Computer History Museum. He maintains the Bitsavers.org site. The actual URL for the MTS materials was changed to
   http://bitsavers.org/bots/univOfMichigan/mts/
shortly after Al posted his message.

Al's posting lead to a few more messages on the CC Talk list which were fun to see:

Jason McBrien
Thu Dec 22 18:17:18 CST 2011
Outstanding! I cut my teeth on MTS at Wayne State University in Detroit, they were still chugging away on an old Amdahl for Email and SPSS. I believe it was the last running mainframe implementation of SPSS, until SPSS cranked up the licensing fee so much the university relented and bought a (more expensive) site-license for Windows. Time to fire up Hercules!
Brent Hilpert 
Thu Dec 22 18:42:47 CST 2011
Indeed; Wow! MTS was the big campus timesharing system from the 70's  
to 90's at UBC.
Never expected to see it available like this.
Lyle Bickley
Fri Dec 23 10:12:17 CST 2011
This is great news! While I was working at IBM's Poughkeepsie Dev. Lab. in the 60's and early 70's, Bernard Galler (U of M) used to be a regular guest at the Lab. He lectured us on the MAD programming language and, of course, "The Michigan Terminal System" (MTS). His lectures ranged from the internals to the practical uses of MTS. He was very critical of IBM's lack of direction with regards to time sharing - and hence tried to "convert" as many of us development folks as possible into becoming timeshare advocates! After months of attending his lectures - he would get huge ovations when he would chastise IBM for not moving in the direction of "real" time sharing ;-) According to Wikipedia, MTS "still runs using IBM S/370 emulators such as Hercules, Sim390, and FLEX-ES". http://en.wikipedia.org/wiki/Michigan_Terminal_System I'll certainly give a shot at getting it running :-)
Cheers, Lyle

Josh Dersch at msu.edu
Thu Dec 22 19:00:26 CST 2011
Very cool! I have a set of MTS-related manuals from 1979, would they be of any interest to you for archival purposes, assuming you don't already have copies? (They are: "Digital Computing, FORTRAN IV, WATFIV, and MTS (with *FTN and *WATFIV)" Parts 1 & 2 by Brice Carnahan and James O. Wilkes.)
  - Josh
Christian Corti at uni-stuttgart.de
Fri Dec 23 05:35:58 CST 2011
That's great!
Is there anywhere a list of supported hardware? I'm not very comfortable 
with the idea of simulator-only software.  I'd be interested to try it 
some day on our 4331.
Christian
Tony Duell at demon.co.uk
Fri Dec 23 16:15:16 CST 2011
That's excellent. Great preservation
  -tony

Al's post lead to this posting on the Hercules-390 Yahoo group on 23 December 2011:

Kevin Monceaux
Fri Dec 23, 2011 9:31 am
Hercules Fans,
I just noticed a couple of posts from Al Kossow on the CCTalk mailing list
concerning MTS. First:
On Thu, Dec 22, 2011 at 02:21:43PM -0800, Al Kossow wrote:
the sources and binaries for MTS are now available under
http://bitsavers.org/bits/UniversityOfMichigan/mts/
Then he notes they had to be moved:
On Thu, Dec 22, 2011 at 04:47:40PM -0800, Al Kossow wrote:
I fixed the line wrap on the readme and copyright files, and noticed the
path was specifed, so I had to move it to
http://bitsavers.org/bits/univOfMichigan/mts/

This lead to more discussion on the Herculies-390 list.

Kevin Monceaux reports successfully IPLing MTS D6.0 from disk at 6:14 AM on 24 December 2011, a day and a half after the first announcement

Kevin Monceaux
Sat Dec 24, 2011 6:14 am
Re: [hercules-390] MTS Successful Restore and IPL (Was: MTS 6.0 Utility Tape Problem?)
Using the above trick I was also able to run the DASDI utility. I found I
also had to mount the Dump/Restore tapes on 3480 drives to perform the
restore. I just finished that and was able to IPL from DASD. I guess it's
time to start browsing through the operations manual.

Not bad for an operating system from 1988.

Discussions continued and are continuing

  • On the Hercules-390 list.
  • On a new H390-MTS Yahoo group that was created on 2 January 2012. Most of the MTS related discussions are occurring there.
  • As of 7 January 2012 several more people have reported success in restoring the D6.0 MTS system from "tape" and getting it to run under Hercules, although this is not for the faint of heart or the inexperienced.
  • Gavin Eadie made several screen shots available to help people get started.

Several photos of MTS running under Hercules are available here.

MTS distributions available from U-M's Deep Blue on 7 January 2012

And on 7 January 2012 the MTS distribution materials became available on the U-M's Deep Blue digital archive. This is the same material that is available from Bitsavers.org, but packaged a little differently.

See: Deep Blue at the University of Michigan > Archival Collections -- Bentley Library > Computing Center (University of Michigan) Records > Michigan Terminal System (MTS) Distribution Files

Thanks

We owe a tremendous debt to Tom Valerio and Mike Alexander for preserving the MTS distribution materials and the 1996 MTS system that was running at U-M.

Tom has done a lot of work over the years using MTS on various S/370 emulators.

In July 2010 Gavin Eadie and Jeff Ogden (me) approached the U-M to get permission to make the MTS distribution materials available. We got a sympathetic reception from Marvin Parnes, U-M's long time Associate Vice-President for Research and Jack Bernard in the U-M General Counsel's office.

Tom, Mike, Gavin, and Jeff worked and are working with the staff at the U-M's Bentley Historical Library to preserve materials related to MTS and to make many of them available in U-M's Deep Blue digital archive. We are thankful for the reception we received from staff at the Bentley including Nancy Deromedi, Richard Adler, Nancy Bartlett, Greg Kinney, and Rasmus Falk. Rasmus is the digital archivist from the City of Aalborg, Denmark who visited Ann Arbor in the summer of 2011 and was working on projects with the staff at the Bentley.

Mike did most of the work to make the MTS distribution materials available at Bitsavers and Deep Blue. He had some help from Gavin and Jeff. We thank Al Kossow of the Computer History Museum and Bitsavers.org for his support and willingness to make MTS available on Bitsavers.


#4: CSMP running under D6.0 MTS under Hercules in January 2012

posted Jan 7, 2012, 11:54 AM by Jeff Ogden   [ updated Jan 13, 2012, 5:30 PM ]

photograph of a 3270 display showing CSMP running under MTS under Hercules
            CSMP under MTS under Hercules, c. January 2012

From: "Dave"
Subject: [H390-MTS] CSMP on MTS
Date: January 7, 2012 10:24:34 AM EST
To: "H390 MTS Group" <H390-MTS@yahoogroups.com>

Folks,
 
Well I am very happy with this. I now have my sample CSMP program from “Applied Numerical Methods for Digital Computation with Fortran and CSMP” 2nd Edition by James, Smith & Wolford working after one minor typo. In case any one wants to try the source is below :-
 
INITIAL
CONSTANT W=10.0,C=0.00259,A=-0.6,B=1.0,K1=.255,K2=1.025
INCON X0=0.0,XDOT0=8.0
     M=W/386.
     COEF=C/M
DYNAMIC
NOSORT
      IF(X.GT.0)GOTO 2
      F0FX=K1*DEADSP(A,0.,X)
      GOTO 3
  2   F0FX=K2*DEADSP(0.,B,X)
  3   CONTINUE
SORT
      XDDOT=-COEF*XDOT-F0FX/M
      XDOT=INTGRL(XDOT0,XDDOT)
      X=INTGRL(X0,XDOT)
TERMINAL
      KE=0.5*M*XDOT**2
      WRITE(6,4)KE
  4   FORMAT(' ',E16.7)
TIMER DELT=0.05,OUTDEL=0.2,FINTIM=60.
METHOD RKSFX
LABEL SPRINT MASS VISCOUSLY DAMPED WITH DEAD SPACE
PRTPLOT XDOT,X,F0FX
END
STOP
ENDJOB
 
Giving the first few lines of print out :-
 
SPRINT MASS VISCOUSLY DAMPED WITH DEAD SPACE                       PAGE   1
 
                        MINIMUM             XDOT   VERSUS TIME           MAXIMUM
                      -7.6828E+00                                      8.0000E+00
TIME          XDOT        I                                                I
0.0           8.0000E+00   -------------------------------------------------+
2.0000E-01    7.0260E+00   ----------------------------------------------+
4.0000E-01   -1.2600E+00   --------------------+
6.0000E-01   -7.6546E+00   +
8.0000E-01   -7.5684E+00   +
1.0000E+00   -6.4429E+00   ---+
1.2000E+00   -2.9557E+00   ---------------+
1.4000E+00    1.5774E+00   -----------------------------+
1.6000E+00    5.4257E+00   -----------------------------------------+
1.8000E+00    7.1513E+00   -----------------------------------------------+
2.0000E+00    7.0579E+00   ----------------------------------------------+
2.2000E+00    4.4652E+00   --------------------------------------+
2.4000E+00   -3.6665E+00   ------------+
2.6000E+00   -6.8152E+00   --+
2.8000E+00   -6.6794E+00   ---+
3.0000E+00   -5.2724E+00   -------+
3.2000E+00   -1.9047E+00   ------------------+
3.4000E+00    2.1148E+00   -------------------------------+
3.6000E+00    5.2571E+00   -----------------------------------------+
3.8000E+00    6.3542E+00   --------------------------------------------+
4.0000E+00    6.2285E+00   --------------------------------------------+
4.2000E+00    3.7196E+00   ------------------------------------+
4.4000E+00   -3.4711E+00   -------------+
4.6000E+00   -6.0134E+00   -----+
4.8000E+00   -5.8943E+00   -----+
5.0000E+00   -4.9065E+00   --------+
 
Thanks to every one from the MTS team for making this possible. Now I need to start updating my CSMP web pages....
 
Dave
G4UGM

#2: 3270 terminal emulators

posted Jun 27, 2011, 5:46 PM by Jeff Ogden   [ updated Dec 6, 2015, 6:59 AM ]

If you want to use MTS with Hercules, you'll need a 3270 terminal emulation program. Here are some hints:

tn3270 for the Macintosh, see  https://www.brown.edu/cis/tn3270/index.html#latest  or   http://www.brown.edu/cis/tn3270/

Vista tn3270 for Windows, see http://www.tombrennansoftware.com

See  http://x3270.bgp.nu/  for:
  • x3270, an IBM 3270 terminal emulator for the X Window System and Windows. It runs on most Unix-like operating systems -- e.g., Linux, Mac OS X, Solaris, and Cygwin. It also runs natively on Windows.
  • c3270, a curses-based version for use on a dumb terminal (e.g., a serial terminal or a Linux console).
  • wc3270, a Windows console version of c3270.
  • Also available is x026, an IBM 026 Keypunch emulator :-).
See  http://h3270.sourceforge.net/  for:
  • h3270, a program that allows you to use IBM 3270 hosts from within a web browser.
The programs listed above, except for Vista tn3270, are available for free.  Vista tn3270 costs just $30 (January 2012). There are also many non-free 3270s terminal emulators available and probably additional free versions as well.

On 21 June 2011 Mike Alexander reported:
x3270 is available via MacPorts (http://www.macports.org/ and https://trac.macports.org/browser/trunk/dports/x11/x3270/Portfile).  I just installed it and it seems to work ok once I figured out that you can't connect to "localhost" since that tries an IPV6 connection which doesn't work (probably because Hercules doesn't support it), and it won't fall back to IPV4.

The Hercules General Information document has additional information about tn3270 clients.



From: Steven J Gold
Subject: [H390-MTS] New version of tn3270 released for OSX 10.9
Date: November 10, 2013 9:48:19 PM EST
To: h390-mts@yahoogroups.com
Reply-To: H390-MTS@yahoogroups.com

FYI:
tn3270 is a terminal emulation program for connecting to computers which use IBM 3270 terminals. Major features of the emulation include color, extended highlighting, support for different screen and font sizes, and SSL support. Some more obscure features include support for the APL character set, and support for file transfer and remote printing when tn3270 is used with an IBM VM/CMS host. The Classic version of tn3270 also supports 3179 graphics emulation.

There is no license fee for either commercial or non-commercial use of the tn3270 application. The tn3270 source code is freely-licensed for non-commercial use, but must be licensed for commercial use.

****What's new in this version: Version 3.4.0 is an update to version 3.3 that supports OS X Mavericks***. It also includes experiment support for the tn3270e protocol and for client SSL certificates.

- - - - -
Read more: tn3270 for Mac - Free download and software reviews - CNET Download.com http://download.cnet.com/tn3270/3000-20432_4-75860370.html#ixzz2kIjzqVI5

#1: MTS and Hercules in 2010

posted Sep 13, 2010, 9:06 PM by Gavin Eadie   [ updated Jan 7, 2012, 12:38 PM by Jeff Ogden ]

You can read about the history of MTS here, but I wanted to show a little of MTS running today on my MacBook Pro laptop. The version of MTS I am using is not generally available, so this entry begs the question of how to make it so. That question has no simple answer as I write this, but we're working on it.

To run MTS you need to obtain an IBM S/370 mainframe or one of the derivatives of that family of mainframes.  Luckily, this is a lot easier than it used to be. Hercules is an open source software implementation of the mainframe System/370 and ESA/390 architectures, in addition to the new 64-bit z/Architecture. Hercules runs under Linux, Windows (98, NT, 2000, and XP), Solaris, FreeBSD, and Mac OS X (10.3 and later).

This discussion shows a little of MTS running under Hercules on my MacBook Pro laptop.  Until we find a way to distribute MTS, there's no point in covering the details of how I managed this (that'll come later), so this first part is mostly "show and tell." Hercules is run from the command line, reads a configuration file which describes the available (emulated) hardware and waits to be IPL'd. Once the initial program is loaded, and started, it proceeds through a sequence of steps, managed from the operators console, till enough of MTS is running to allow terminals to be enabled and offer access to the interactive service.

Operator Console:
MTS signon screen:
MTS "TimeSpelledOut" and $SystemStatus:

1-9 of 9